My CallPilot requires that you use one of the following Web Browsers:
  • Microsoft Internet Explorer version 5 (or higher)
  • Netscape Communicator/Navigator version 6 (or higher)

Please use one of the supported browsers to access My CallPilot.